Login and form issues
Incident Report for Webconnex
Resolved
This incident has been resolved and all functionality restored.
Posted Apr 13, 2023 - 14:12 PDT
Investigating
We are currently experiencing issues with both login and accessing live forms. Our team is actively investigating
Posted Apr 13, 2023 - 13:52 PDT
This incident affected: Registration and Control Panel.