Increased failure rate of Webconnex Payments Transactions

Incident Report for Webconnex

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 16:41 PDT

Monitoring

The issue impacting payment processing has been resolved. We are currently monitoring to ensure all transactions continue to process without any issues.

Additionally, we are verifying transaction records to ensure that all successful charges have been accurately reported to customers. We’ll provide a final update once monitoring is complete.

Thank you for your continued patience.
Posted Apr 21, 2025 - 11:15 PDT

Investigating

We’re currently investigating an issue impacting payment processing.
One of our upstream partners is experiencing temporary performance issues, which may be affecting payment processing. Our team is actively investigating and working closely with them to resolve the issue.

We’ll share updates as soon as we have more information. Thank you for your patience.
Posted Apr 21, 2025 - 10:28 PDT
This incident affected: Payment Gateways (Webconnex Payments).